The LP5 system board comes with the Windows and DOS application package for the onboard Creative CT2504 chip.   This chapter tells how to use these applications.


Driver Installation


To install the drivers, simply insert the Audio Installation Disk into drive A and type:


A:\INSTALL


Follow the screen instructions to complete the installation.


Windows Applications


WaveEditor


WaveEditor allows you to record, play, edit  and enhance 8-bit (tape quality) and 16-bit (CD quality) wave data in the Windows environment.   


Starting WaveEditor


To start WaveEditor, simply double-click on the WaveEditor icon.  The WaveEditor window appears as follows.


�


Toolbar	Contains the buttons and control boxes for file and wave operations.


�
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�����


�


��
Creates a new window without any data.�
�
��
Loads an existing wave file.�
�
��
Saves changes made to a wave file.�
�
��
Cuts the selected data of a wave file.�
�
��
Copies the selected data of a wave file.�
�
��
Pastes cut or copied data onto a wave file.�
�
��
Plays the wave file that is currently active in the WaveEditor.�
�
��
Stops the playback of a wave file.�
�
��
Pauses/Resumes the playback of a wave file.�
�
��
Records a wave file.�
�
��
Sets the default recording format.�
�
��
Activates the mixer.�
�
��
Activates the CD player.  (This button appears only if you have a CD-ROM drive installed.)�
�
��
Displays the starting position of the wave data selection.  To specify the position, enter the numerical value in the text box or use the scrolls to select the starting position.�
�
��
Displays the size of the wave data selection.  To adjust the size, enter the desired size in the text box or use the scroll arrows.�
�
��
Displays the zoom ratio of the wave file on display.  To adjust the ratio, simply enter the desired ratio in the text box or use the scroll arrows.  The smaller the value, the larger the magnification.�
�
�
Edit Window	Refers to the area where the content of a wave file is displayed.  You can open several edit windows at the same time.  This allows you to perform editing functions quickly and easily.


�


Status Bar	Displays information related to the wave file in the active edit window and each menu command. 


�


WaveEditor Menus


WaveEditor has seven menus.  It also has a context-sensitive menu that you can activate easily with your mouse.


File


The File menu contains the following commands:


New	Creates a new window without any data.


Open	Loads an existing wave file.


Close	Closes an open wave file.


Close All	Closes all open wave files.


Save	Save changes made to the wave file.


Save As	Saves the wave file with a new name.


Save All	Saves all open wave files.


Exit	Quits WaveEditor. 


WaveEditor keeps a record of the last four wave files that you have opened by displaying them on the File menu after the Exit command.  To open any of the files, select the file with the left mouse button.


Edit


The Edit menu contains the following commands:


Undo	Restores the wave file to the state last saved.


Cut	Copies and then removes the selected portion of the wave data.


Copy	Copies the selected portion of the data.


Paste	Pastes cut or copied wave data into the Edit window.


Paste Mix	Mixes cut or copied wave data with the one in the Edit window.  


Delete	Deletes a selected portion of the data.  Unlike the Cut command, the data is not copied first.


Crop to Selection	 Deletes the entire data except the portion selected.


Select All	Selects the entire wave file in the Edit window.  You can also do this by double-clicking the mouse anywhere within the Edit window.


View


The View menu allows you to customize the WaveEditor workspace:


Toolbar	Toggles the Toolbar on or off.


Status Bar	Toggles the Status bar on or off.


Fit Wave In Window	Scales (adjusts the zoom ratio) the wave display to fit the size of the Edit window.


Actual Size	Resets the zoom ratio of the wave display in the Edit window to its actual size.


Cursor Position	Displays the wave file at the starting point of the wave selection.


Cursor End	Displays the wave file at the ending position of the wave selection.


Zoom	Zooms into the portion of the wave file.


Special Menu


The Special menu allows you to add special effects to the wave files.  


Reverse	Reverses the playback of the entire or selected portion of the wave file.


Add Echo	Adds echo effect to the entire or selected portion of the wave file.  


Rap!	Repeats the selected portion of the wave file.


Insert Silence	Inserts silence into the selected wave file portion.


Force to Silence	Silences the selected wave file portion.


Fade In	Fades into the entire or selected wave file portion.


Fade Out	Fades out the entire or selected wave file portion.


Amplify Volume	Changes the volume level of the entire or selected wave file portion.


��
For stereo files, options for editing each channel are available.�
�
Options Menu


The Options menu lets you change the WaveEditor’s default settings.


Record Settings	Sets the default record settings.


Mixer Settings	Activates the mixer.


Display in Bytes	Displays the wave selection information in bytes.


Display in Samples	 Displays the wave selection information in milliseconds.


Always on Top	Toggles WaveEditor as the topmost window.


Window Menu


The Window menu allows you to organize the Edit windows when several wave files are open.  Refer to your Microsoft Windows manual for more information on Windows menu commands.


Help Menu


The commands on the Help menu are:


Contents	Displays the WaveEditor’s menu contents.


Search	Searches the Help menu based on your selected topic.


System Information	 Displays the information about Windows and your system such as CPU and available memory.


About WaveEditor	Opens a window displaying copyright information.


Context-sensitive Menu


The Context-sensitive menu appears when you click the right mouse button in the Edit window.  It contains the following commands:


Play	Plays the entire or selected portion of the wave file in the Edit window.


Record	Records a wave file.  If the current active window in the Edit window is an open file, the recorded file replaces the contents in the open file.


Stop	Stops the playback of a wave file.


Mixer Settings	Activates the mixer.


Fit Wave in Window	   Scales the wave display to fit the size of the Edit window.


Cursor Position	Displays the wave file at the starting position of the wave selection.


Zoom	Zoom into the portion of the selected wave file.


New	Creates a new window without any data.


Open	Loads an existing wave file.


Save	Saves changes made to the wave file.


Working with WaveEditor


Specifying Wave Formats


Before recording a wave file, make sure that the format of the file is specified correctly.  Wave format refers to the sound channel and sampling rate and file size.


To specify the wave format:


1.	Select Record Setting from the Options menu.  See the following figure.


�


2.	Select the format of the wave file.  


Select Mono for single-channel sound and Stereo for dual-channel sound.


Select 11025 Hz for voice-, 22050 Hz for cassette- and 44100 Hz for CD-quality recording.


Select 8 bits for cassette and 16 bits for CD-quality sound.


3.	Select OK.


��
A wave file with better sound quality requires greater space because of its high sampling rate.  Therefore, the amount of storage space required for a file depends on the quality of a wave file�
�
�
Opening Wave Files


You can open a wave file using the Open command from the File menu or the drag-and-drop method.


To use the Open command:


1.	Select Open from the File menu.  The Open Sound File dialog box appears.


�


2.	From the File Name list box, select the file you want to open.  You may have to specify the directory that contains your .WAV files.  Choose Play to listen to the selected wave file.


3.	Choose OK.


��
If you select a file with raw data (.RAW) or Creative’s Voice format (.VOC), a dialog box prompting you to confirm the conversion of the file to .WAV format appears on screen.�
�
To use the drag-and-drop method:


1.	Start File Manager and open the directory containing the wave file.  


2.	Arrange the windows in such a way that the file and the WaveEditor windows fit the screen.


3.	Hold the left mouse button as you drag the file into the WaveEditor window. 


4.	Drop the file by releasing the mouse button.  The file opens automatically.


��
You may open multiple files using the drag-and-drop method by holding the j key and clicking on the files in the File Manager.�
�
Recording Wave Files


To record a new file:


1.	Choose New on the Toolbar.


2.	Choose Record on the Toolbar.  The New Recording dialog box appears.


�


3.	Make sure that the settings in the dialog box are properly specified.


Check the record level in the Recording Level group box.  Adjust the level using the Mixer button (if necessary).


Check the path and the filename created in the Record to File group box.  Change the filename and the directory using the Browse button.


Check the recording format as shown at the bottom of the dialog box.  To change the format, select the Settings button.


Check your system’s storage space as shown at the bottom of the dialog box.  Make sure that you have sufficient storage for your file.


4.	Choose Start.


��
If you have a CD-ROM drive installed, select the CD Player button to activate the CD player.  Also, select the CD Sync check box to synchronize the start of the recording and playback of audio CDs.�
�
To record over an existing file:


1.	Activate the file you want to record over.


2.	Choose Record on the Toolbar.  The Record Over dialog box appears.


�


3.	Choose Start.


Saving Wave Files


To save a wave file:


1.	Choose Save on the Toolbar or select Save from the File menu.


2.	Enter the name of the file and the path, if prompted.


3.	Choose OK.


To save a wave file with a new name or format:


1.	Select Save As from the File menu.  The Save Sound File dialog box appears.


�


2.	Enter a new name for the file and the path, if prompted.


3.	Select the desired file format and the compression method from the Save File as Type and Compression/Conversion drop-down list boxes, respectively.


4.	Choose OK.


Mixing the Data of Different Wave Files


To mix the data contents of two wave files:


1.	Activate the first (source) file and select the desired portion of the file for mixing.


2.	Select Copy from the Edit menu.  The data copied is stored in an internal buffer.


3.	Activate the second (target) file and select the location where you want to insert the copied data.


4.	Select Paste Mix from the Edit menu.  The Paste Mix dialog box appears.


�


5.	Select the desired channels for copying data from the source file in the From Buffer User group box and for mixing data with the target file in the Mix With Wave group box.


Select Mono Channel for a mono file.


Select Left Channel, Right Channel, or Both Channels for a stereo file.


6.	Choose OK.


If you did not select a portion of the target file, the data is mixed at the cursor position.  If you select a portion of the target file, the copied data in the buffer is mixed with the selected portion.


��
You cannot mix 8-bit wave data with 16-bit wave data.  However, you can convert both files to either 16-bit or 8-bit sampling size before mixing them.�
�
Adding Special Effects


WaveEditor allows you to enhance your wave files with special effects from the Special Menu.  These effects are as follows:


REverse


This effect reverses the sequence of the data in the wave file such that the sound is played backwards.  You must specify the portion of the file that you want to reverse. Otherwise, this effect reverses the entire file.


To reverse a file:


1.	Select Reverse from the Special menu.  The Reverse dialog box appears.


�


2.	Select the desired channels.  No options are available for editing a mono file.  


	Select Left Channel, Right Channel, or Both Channels for stereo file.


3.	Choose OK.


Add Echo


This effect modifies data in the wave file to give an echo effect.  


To add echo to a file:


1.	Select Add Echo from the Special menu.  The Add Echo dialog box appears.


�


2.	Enter the echo magnitude (loudness of the echo) in the Magnitude text box.


3.	Enter the echo delay (the time between the actual sound and the echo) in the Echo Delay text box.


4.	Select the desired channel for stereo files.


5.	Choose OK.


Rap!


This feature repeats the selected portion of the wave file.  This is useful when you want to create a jerky or stuttering effect for your voice files.


To repeat a selection:


1.	Select a portion of a file.


2.	Select Rap! from the Special menu.


Insert Silence


This effect inserts silence into a selected portion of a wave file.


To insert silence into a file:


1.	Select a portion of the wave file.  The length of silence depends on the length of the portion selected.


2.	Select Insert Silence from the Special menu.


The straight line inserted into the selected portion represents the inserted silence.  


Force to Silence


This effect mutes the selected portion of a wave file during playback.  


To mute a file:


1.	Select a portion of the file.


2.	Select Force to Silence from the Special menu.  The Force to Silence dialog box appears.


�


3.	Select the desired channels.  No options are available for editing a mono file.


	Select Left Channel, Right Channel, or Both Channels for stereo wave file.


4.	Choose OK.  The selected portion is replaced by a straight line.


Fade In and Fade Out


To use Fade-in or Fade-out:


1.	Select Fade In from the Special menu.  The Fade In dialog box appears.


�


2.	Enter the starting magnitude in the Magnitude text box.


3.	Select the desired channels for stereo files.


4.	Choose OK.


��
The file is fades in linearly from the starting magnitude (volume) to a 100% magnitude (volume) for Fade In, and from 100% magnitude to the ending magnitude for Fade Out.�
�
Amplify Volume


This effect allows you to change the volume of wave files.  


To change the volume of a file:


1.	Select Amplify Volume from the Special menu.  The Amplify Volume dialog box appears.


�


2.	Enter the magnitude in the Magnitude text box.


3.	Select the desired channels.


4.	Choose OK.


Customizing the Wave Editor


Recording


To customize the record settings:


1.	Select Record Settings from the Options menu.  The Record Settings dialog box appears.


2.	Specify the desired settings.


3.	Choose OK.


Mixer


To adjust the Mixer settings:


1.	Choose Mixer on the Toolbar.  The Mixer window appears.


2.	Specify the desired settings.


Using WaveEditor Effectively


To use WaveEditor effectively, you need to know the amount of memory needed to run WaveEditor, how to manage your files and how to work with compressed files.


Memory REquirements


WaveEditor requires about 1 MB of memory.  Memory requirements increase when you playback or record wave files, as sufficient memory is needed for the buffers.  We recommend that you run WaveEditor on at least a 386-based system with 4 MB of RAM under Windows 3.1.


When you open a file for editing, WaveEditor allocates a certain amount of memory for storing the necessary information and does not load the entire file into memory.  The file is edited directly from your hard disk.  Therefore, you can edit files as large as your hard disk can accommodate.


File Management


System Optimizing	When you record wave data, WaveEditor stores recorded data directly to the hard disk.  High-resolution recording of data, particularly 16-bit data at 44 kHz, takes a longer time to write to your disk if it is not optimized for speed.    


To reduce the amount of time your system spends reading and  writing data, compact your hard disk using a disk-compaction utility such as DEFRAG and install a hard disk cache such as SMARTDrive.


Number of Open Files	WaveEditor does not limit the number of files that you can open.  The number of files WaveEditor can open at a time depends on how you configure your operating system.  For more information on how to do that, consult your operating system’s documentation.


Use of DOS SHARE Utility	We recommend that you use the DOS SHARE utility to allow proper file sharing and locking.  This prevents accidentally deleting a file while WaveEditor is accessing it.  For more information on how to use this utility, consult your DOS documentation.


Compressed Wave Files


Opening Compressed Files	WaveEditor currently supports five compression formats: Microsoft ADPCM, CCITT A-Law, CCITT µ-Law,  IMA/DVI ADPCM, and Creative ADPCM.  


When you open a compressed wave file, WaveEditor decompresses the file before displaying it.  You must ensure that the file resides on a drive that has sufficient disk space to accommodate the uncompressed data.


The amount of space required depends on the compression format adopted.  For CCITT A-Law and µ-Law, the compression ratio is 1:2 (compressed:uncompressed).  For ADPCM, the ratio is 1:4.  For example, if you are working with a 1 MB ADPCM file,  you need to have at least 4 MB of free disk space.


Editing Compressed Files	When you open a compressed wave file for editing, WaveEditor automatically compresses the file when you save it.   As this can be time consuming for large files, you should save your work as an uncompressed wave (PCM) file first.  Once you have finished editing, save the file with the desired compression format.


�
Using CD Sync


The CD synch allows you to synchronize the recording and playback of audio CDs.  This option is only available if you have a CD-ROM drive installed in your system.


Recording continues even if you have mistakenly placed a CD-ROM disk in your drive.  However, the program informs you that there is an error.  To stop the recording, select Stop on the Toolbar.  Insert the correct audio CD and click on Record on the Toolbar to record over your file.  To disregard the CD Sync option, uncheck it before you proceed with the recording.


Quitting WaveEditor


To quit WaveEditor, simply select Exit from the File menu.  A dialog box prompts you to save the changes that you have made ( e.g., if the changes to the file have not been saved).  


QuickCD


QuickCD allows you to play audio compact discs (CDs) in Windows.  


Setting Up QuickCD


To use the QuickCD, you need to install the MCICDA.DRV driver that comes with your Windows 3.1 package.  The MCICDA.DRV is the device driver that allows you to play audio CDs in Windows.


To add the MCICDA.DRV:


1.	Double-click on Control Panel in the Main group window.  The Control Panel group window appears.


�


2.	Double-click on Drivers in the Control Panel window.  The Drivers dialog box appears.


�


3.	Check if the statement [MCI] CD Audio appears in the Installed Drivers list box.  


If the statement [MCI] CD Audio appears in the Drivers dialog box, choose Close to exit the Drivers dialog box.  Proceed to run QuickCD.  


If the statement [MCI] CD Audio does not appear in the Drivers dialog box, follow steps 4, 5, 6, and 7 to add this statement.


4.	Choose Add... from the Drivers dialog box.  The Add dialog box appears.


�


5.	Select [MCI] CD Audio from the Add dialog box.


6.	Choose OK.


7. 	Restart Windows for the changes to take effect.


Starting QuickCD


After you have set up QuickCd, run the program from your Accessories group window.


To start QuickCD, simply double-click on the QuickCD icon.  The QuickCD window appears.








�
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��


The QuickCD Window


The QuickCD window has the following features:


On/Off switch	Quits QuickCD.


Eject button	Opens or closes the tray.  Disregard the function if your drive does not support software eject.


Play button	Plays the track shown in the Display box.


Stop button	Stops the track.


Pause button	Pauses or resumes play.


Previous Track button	Plays the previous track.  


Rewind button	Rewinds the current track by 10 seconds.  If the current track is the first track, this feature does not function.


Fast Forward button	Forwards the current track by 10 seconds.  If the current track is the last track, this feature does not function.


Next Track button	Plays the next track.  


Mixer button	Starts the mixer.


Slider thumb	Shows the progress of the playing track.  It also allows you to rewind or forward the current track.


Track Selection buttons	Allow you to select the desired track.  If there are more than 20 tracks, choose � to display the rest of the tracks.


Display box	Displays the current track and duration of the track.


Control-menu box	Activates the Control menu.


The Playlist Button	


The Playlist button allows you to compile a selection of the tracks that you want to play.  The CD Playlist dialog box appears if you select the Playlist button.





The CD Playlist dialog box contains the following:


CD Artist/Title   Allows you to name your CD.


Track Title   Allows you to name the tracks on your CD.


Playlist   Displays the tracks that are in the playlist.


Tracklist   Displays the tracks on your CD.


Play/Stop   Plays the selected tracks in the Playlist or Tracklist list box.


Add   Adds the selected tracks in the Track List list box to the Playlist list box.


Add All   Adds all tracks in the Track List list box to the Playlist list box.


Remove   Removes one or more tracks from the Playlist list box.


Done   Confirms the compilation of the tracks in the Playlist list box.


Cancel   Cancels changes made to the track in the Playlist list box.  The playlist reverts to its last saved copy.


Help   Displays the online help facility.


You may use a mouse or a keyboard to select an option.  To select an option with a mouse, simply click on the button of the desired option.  To play the selected track, simply click on the Track Selection button.  To forward or rewind the current track, drag the slider thumb.


To select an option using a keyboard, press v then e to activate the selected option.  To move the slider thumb, use the left or right arrow key.  To select the Control-menu box, press a-k.


Using the Control Menu


The Control menu includes commands that enable you to perform various operations such as move, restore, and close the window.


To activate the Control menu:


1.	Click on the Control-menu box.  The Control menu appears onscreen.


�


Menu Commands


Restore	Restores QuickCD icon to its control window.


Move	Allows you to move QuickCD around the desktop.


Minimize 	Reduces QuickCD to an icon.


Close	Quits QuickCD.


Switch To 	Opens the Task List dialog box which allows you to select another application.


Play 	Plays the current track.


Stop	Stops the track.


Pause	Pauses or resumes play.


Skip	Selects the next track and plays it.  


Always on Top	Displays QuickCD on top of the active window.


Preferences	Allows you to customize QuickCD.


Mixer Settings	Activates the mixer.


About QuickCD	Displays the copyright information about QuickCD.


Help	Displays QuickCD Help menu contents.


Customizing QuickCD


To customize QuickCD:


1.	Select Preferences from the Control menu.  The Preferences dialog box appears onscreen.


�


2.	Select the desired options:


Automatically play when CD is inserted   �Plays an audio CD automatically if it is loaded in the disk tray when you start QuickCD.


Continuous playback	�Repeats from track 1 after the final track is played.


Minimize on play	�Minimizes QuickCD to an icon when playing audio CDs.


Stop playback on exit	�Stops an audio CD when you exit QuickCD.


3.	Choose OK.


Quitting QuickCD


To quit QuickCD, do any of the following:


Click on the On/Off switch.


Select Close from the Control menu.


Press a-o.


Wave’OLE


Wave’OLE plays and records wave data.  It has play, pause, rewind, forward, stop and record buttons that allow you to control the wave files.  


Wave’OLE supports Object Linking and Embedding (OLE) that enables you to insert sound into other applications such as write by linking or embedding them.  Refer to the Microsoft Windows manual for more information about object linking and embedding.


Starting Wave’OLE


To start Wave’OLE, simply double-click on the Wave’OLE icon.  The Wave’OLE window appears onscreen.


�
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Wave’OLE Menus


The File Menu


The commands on the File menu are:


New	Creates a new wave file.


Open	Opens an existing wave file.


Save	Saves the wave file.


Save As	Saves the wave file with a new name.


Exit	Quits Wave’OLE.


Wave’OLE keeps a record of the last four files that you have opened.  These appear at the end of the pull-down list in the File menu.  To open one of these files, click the file with the left mouse button.


�
The Edit Menu


The command on the Edit menu is:


Copy Sound as an Object	Copies the sound data and OLE information to the clipboard.  You can pass the sound data onto an OLE client as an embedded or linked object.


The Options Menu


The commands on the Options menu are:


Wave Info...	Displays information about the sound data such as the sampling rate and size.


Mixer Settings...	Runs the Mixer application.  See the chapter on Windows mixer for more information.


Recording Settings...	Lets you set the sampling size, frequency, and mono or stereo mode for recording.


Always on Top...	Toggles Wave’OLE as the topmost window.


The Help Menu


The commands on the Help menu are:


Contents	Displays Wave’OLE Help menu’s contents.


About Wave’OLE	Opens a window displaying copyright information.


�
Opening a Wave File


To open a wave file:


1.	Select Open from the File menu.  The File Open dialog box appears.


�


2.	Type or select the wave file that you want to open.  Choose Play to preview the file before opening it.  The dialog box also gives you the wave format, data size and file date information.


3.	Choose OK.


Playing a Wave File


To play a wave file:


1.	Open the wave file.


2.	Click on Play.


To stop playing the wave file, select Stop.


You may control the operations in the Wave’OLE windows with either a mouse or a keyboard.  To move around the Wave’OLE windows, use the v or the left and right arrow keys, or simply drag the slider thumb with a mouse.  To select a button, press k or click on the desired button.  


Recording a Wave File


To record a wave file:


1.	Select New from the File menu.


2.	Choose Record.  The Recording dialog box appears.


�


To stop the recording, choose Stop.


�
Setting Recording Characteristics


To set recording characteristics:


1.	Select Recording Settings from the Options menu.  The Recording Settings dialog box appears.


�


2.	Select the desired settings.


Select Mono for a single-sound channel and Stereo for dual-sound channels.  Mono is suitable if you want to perform voice recording, while stereo is more suitable for music recording.


If you do not select a compression method, select the 8-bits option for normal recording and 16 bits for high-quality recording.  ��If you select a compression method from the Compression drop-down list, the 8-bit and 16-bit options are grayed out.


Select 8 KHz or 11 KHz frequency for voice-quality sampling rate, 22 KHz for tape-quality sampling rate, and 44 KHz for CD-quality sampling rate.


Choose OK. 


Embedding a Wave File


��
When you embed a wave file, you load a copy of the wave file in Wave’OLE and transfer it to an application such as Write that supports object linking and embedding (OLE).  If you edit the wave file in Wave’OLE, the wave file in Write is not affected because you no longer have any connection to the file in Write.�
�
You can embed a wave file using two methods:


From a document


From Wave’OLE


To embed a wave file starting from Write:


1.	Open the Write document where you want to embed a wave file.


2.	Select Insert Object from the Edit menu.  The Insert Object dialog box appears onscreen.


�


3.	Select Wave’OLE.


4.	Choose OK.  The Wave’OLE application opens.


5.	Select Open from the File menu to select an existing wave file (or you can do a recording and save it into a new file before you include the file in the document).


6.	Choose OK.


7.	Select Update Write from the File menu.  This embeds the wave file into the Write document and an icon representing the wave file is placed in Write.


8.	Select Exit and Return to Write from the File menu.  This returns to the Write document.


To embed a wave file starting from Wave’OLE:


1.	Open Wave’OLE.


2.	Record a new wave file or open an existing wave file that you want to embed.


3.	Choose Copy Sound as an Object from the Edit menu.  This places the wave file into the clipboard.


4.	Open the Write document where you want to embed the wave file.


5.	Select Paste Special from the Edit menu in Write.  The icon representing the embedded wave file appears.


�
Linking a Wave File


��
When you link a wave file, you are not making a copy of the wave file.  You are only making a reference to the wave file.  If you edit the wave file in Wave’OLE, the wave file in an application such as Write reflects those changes.�
�
To link a wave file in Write:


1.	Open Wave’OLE.


2.	Create a new wave file or open an existing file that you want to link.


3.	Save the wave file.


4.	Choose Copy sound as an object from the Edit menu.


5.	Open the Write document where you want to link the wave file.


6.	Select Paste Link from the Edit menu in Write.  The icon representing the wave file appears.


Quitting Wave’OLE


To quit Wave’OLE:


1.	Select Exit from the File menu.  The Wave’OLE dialog box appears if you have not yet saved the latest changes.


�


2.	Choose Yes to save the changes, No to quit without saving the changes, or Cancel to continue working in Wave’OLE.


Mixer Control


Mixer Control is a Windows-based audio mixer that allows you to combine and manipulate sound from various audio sources.  With the mixer, it is possible to control the volume of an audio source while running other Windows applications, select and mix different audio sources during record and playback.


Starting the Mixer


To start the mixer, simply double-click on the Mixer control icon.  The Mixer Control window appears onscreen.


�


The Mixer Control Window


Device Control group box


The Device Control group box contains sliders that control the volume of various sources that your audio chip supports. 


�


��
All of the above sources are in stereo except Microphone and PC Speaker.  Stereo sources have two sliders to control the volume from the left and right channels.  Mono sources have one slider to control one channel.�
�
Master Volume group box


The Master Volume group box contains sliders that control the overall volume from your external speakers.


�


Output group box


The Output group box contains check boxes that allow you to listen to or mute the audio from the CD-audio, line-in, and microphone.


�


��
You cannot mute the other mixer sources.  For example, if you play audio from a MIDI source, you can hear the audio if the volume is at an audible level.�
�
Menu Bar


The Menu bar consists of three drop-down menus.


Setting


The Settings menu contains the following commands:


Recording	Displays the Recording Control window.


Exit	Quits the mixer.


�
Options


The Options menu contains the following commands:


Lock L/R Vol.	Locks both left and right channels of all stereo sources, so that both channels move at the same time when you drag the slider thumb.


Always on Top	Displays the mixer as the top-most window.


Save Setting on Exit	Saves all the changes made to the mixer.  The new setting becomes the default setting when you run the mixer.


Help


The Help menu contains the following:


Contents	Displays the Mixer Control Help menu contents.


About Mixer Control 	States the copyright and credit information about the mixer.


You can select the options on mixer with a mouse or a keyboard.  To use a mouse, simply click the option if it is in a check box.  To adjust the volume, drag the slider thumb or click the top or the bottom of the slider.


To select an option with a keyboard, simply press v.  To adjust the volume, press the up or down arrow key.  To move through the option backwards, press j-v.


�
Selecting a Record Source


The mixer allows you to select one or combination of the following audio sources for recording:


Microphone


Line-in


MIDI device


CD-audio


To select a record source:


1.	Select Recording from the Setting menu.  The Recording dialog box appears onscreen.


�


2.	Click the desired check boxes in the Left Iin and Right In group boxes.  These group boxes allow you to record selected sources to the left and right channels.


	The selected audio source is marked with a red dot.  To get stereo recording, click the check boxes.


3.	To automatically adjust input from the microphone to a level suitable for recording, click the AGC check box.  You need to select at least one of the Microphone check boxes before the AGC check box is effective for recording.


Saving the Mixer Settings


To save the settings before you exit, select Save Setting On Exit from the Options menu.  


Quitting the Mixer


To quit the mixer, do one of the following:


Select Exit from the Settings menu.


Double-click on the Control-menu box.


QuickPlayer


QuickPlayer allows you to play a wide range of multimedia files consisting of sound, animation, movie and video files.  However, before you play a file, make sure that your appropriate software setup supports the type of file that you want to play.


Within the Quickplayer, you can start the mixer to adjust the volume and tone of multimedia files.  If you have installed a CD-ROM drive in your system, you can also start QuickCD to play audio CDs.


Starting QuickPlayer


To start QuickPlayer, simply double-click on the QuickPlayer icon.  The Quickplayer window appears on the screen.


�


Playing Multimedia Files


To play a multimedia file:


1.	Drop the Drives list box and select the drive that contains the desired file.  


2.	Drop the List Files of Type list box and select the type of file to be played.


3.	Select the directory path where you stored the file from the Directories list box.


	The available multimedia files for that path appear in the File Name list box.  


4.	Select a file in the list box.  The selected file appears in the File Name text box.


5.	Click on Play.  Alternatively, double-click the file in the File Name list box.


6.	Click on Stop when you want to stop the file.


You can also play all or a selection of multimedia files in the File Name list box in sequence.  


If you want to play a selection of the multimedia files in the File Name list box, replace Step 4 with the following:


Press and hold b while you select the desired files with the mouse.


When you play a sequence of multimedia files, you can skip a file and go to the next one if you desire.  To skip a file in sequence, choose Skip.


Playing Audio CDs


If you have a CD-ROM drive, you can play audio CDs using QuickCD.


To start QuickCD, select the CDPlayer button to display the QuickCD window.  For more information, refer to the section on QuickCD.


Adjusting the Volume and Tone


You can adjust the volume and tone with the Windows mixer.  To start the mixer, choose the Mixer button to display the Mixer Control window.  For more information, refer to the section on Mixer Control.


Quitting QuickPlayer


To quit QuickPlayer, do one of the following:


Click on Quit.


Double-click on the Control-menu box.


DOS Utilities


Play Utility


The Play utility allows you to play audio CDs and a wide range of sound files such as Microsoft Wave (.WAV), Creative Voice (.VOC), MIDI (.MID) and Creative Music (CMF) files by simply entering a command.  Also, the utility gives you the flexibility to play a set of files with the same extension in sequence without requiring you to specify each file individually.


Knowing the Play Command


You must be familiar with the Play command line before you play sound files or audio CDs.


Command Line for Playing Sound Files


The command line for playing sound files is:


PLAY file1 [file2...] [/Q] [/H] [/?]


where:


file1	is the name of the first file you want to play.  


file2	is the name of additional files of the same type to play.


/Q	Disables display of playback information (file format, play time, filenames, key menu, and the copyright messages) while a file is playing.


/H or /?	Displays description for using Play.


Take note of the following when using Play:


If you enter Play without any parameters, a description for using Play appears.


If you enter a filename without specifying an extension, Play searches the current directory for that filename.  If more than one extension for the filename exists, the utility plays only one file in the following order of preference: .WAV, .VOC, MID and CMF.


Before you play a Creative Music (.CMF) file, you must load the SBFMDRV.COM driver into memory.  To do this, simply type SBFMDRV in the directory where the driver is found.  


When you enter a filename, you can specify part of the filename and use the * or ? characters to represent the remaining missing characters.  The * character represents one or more characters  while the ? character represents only a single character.	��For example, the PLAY *.WAV line plays all wave files.  The PLAY TEST*.WAV line plays all wave files with filename beginning with TEST.  The PLAY TEST?.WAV line plays all wave files with filenames containing five characters and beginning with TEST.  


��
PLAY *.* or PLAY TEST.* lines do not work because PLAY only works with files of one type collectively.�
�
When you play a MIDI file, the program searches for the MIDI environment variable.	��The MIDI environment variable specifies the MIDI file format used and where MIDI data is sent to.  The MIDI data can be sent to the FM chip, Sound Blaster MIDI, or MPU-401 port. Generally, there are three MIDI file formats available: General MIDI, Extended MIDI and Basic MIDI.	�	�The command for setting the MIDI environment is:


SET MIDI=SYNTH:x  MAP:y  MODE:z


SYNTH:x	


		x = 1	Specifies internal synthesizer (default).


		x = 2	Specifies MIDI port.


MAP:y	


		y = G	Specifies General MIDI file format.


		y = E	Specifies Extended MIDI file format (default).


		y = B	Specifies Basic MIDI file format.


MODE:z


		z = 0	Supports General MIDI (default).


		z = 1	Supports Roland Sound Canvas GS.


		z = 2	Supports Roland MT32.


��
MODE: z only applies to Sound Blaster AWE32.�
�
Command Line for Playing Audio CDs


The command line for playing audio CDs is:


PLAY CD [/T:xx] [/Q] [/H] [/?]


where:


CD	Enables the CD-ROM Drive.


/T:xx	Specifies the CD track that you wish to start playing at (xx is the track number).


/Q	Disables display of playback information (current track, total tracks, playing time, and the key menu) while a track is playing.


/H or /?	Displays description for using PLAY. 


��
If you do not specify the track number (/T:xx) option, you must press P to start playing the CD.�
�
Using Play


The following are some examples of how you can play sound files and audio CDs in DOS:


To play a Creative Music File (SONG.CMF):


1.	Make sure SBFMDRV.COM is loaded in memory.


2.	Type PLAY SONG.CMF and press e.


To play three voice files (TEST1.VOC, TEST2.VOC, and TEST3.VOC) in sequence, type PLAY TEST1.VOC TEST2.VOC TEST3.VOC and press e.


��
The command does not function if a file specified does not exist in the directory.�
�
To play a voice file (TEST1.VOC) without displaying the playback information, type PLAY TEST1.VOC /Q and press e.


To play a CD without specifying  the starting track, type PLAY CD and press e.


To play a CD starting at track 5, type PLAY CD /T:5 and press e.


To play a CD starting at track 5 without displaying the CD hot keys, type PLAY CD /T:5 /Q and press e.


Controlling Playback


You can control the playback of files using hot keys.  A menu of the available hot keys appears when you enter PLAY without the /Q switch.


Wave File Control Hot Keys


The following are the hot keys you can use while playing wave files:


C	Resumes playing a wave file after a pause.


^	Stop playing a wave file and exits the program.


N	Plays the next wave file in a specific set.


P	Plays the previous wave file in a specified set.


k	Pauses the playing wave file.


<, > and press e	Selects and plays another wave file if more than one file is specified.


Voice File Control Hot Keys


The following are the hot keys you can use while playing voice files:


B	Stops a repeating section of the voice file and proceeds to the next section.


C	Resumes playing a paused voice file.


^	Stops playing the voice file and exits the program.


N	Plays the next voice file in a specified set.


P	Plays the previous voice file in a specified set.


k	Pauses the playing voice file.


<, > and press e	Selects and plays another voice file if more than one file is specified.


MIDI File Control Hot Keys


The following are the hot keys you can use while playing MIDI files:


C	Resumes playing a paused MIDI file.


^	Stops the MIDI file (if one is playing) and exits the program.


x, z	Reproduces the sound in a different key by raising or lowering the pitch.


M	Changes to a different set of musical instruments based on the basic, general, and extended standards on the MIDI mapper. 


N	Plays the next MIDI file in a specified set.


P	Plays the previous MIDI file in a specified set.


^	Pauses the playing MIDI file.


w, y	Changes the tempo of the MIDI file. 


<, > and press e	Selects and plays another MIDI file if more than one file is specified.


CMF File Control Hot Keys


The following are the hot keys you can use while playing CMF files:


C	Resumes playing a paused CMF file.


^	Stops the CMF file (if one is playing) and exits the program.


x, z	Reproduces the sound in a different key by raising or lowering the pitch.


N	Plays the next CMF file in a specified set.


P	Plays the previous CMF file in a specified set.


k	Pauses the playing CMF file.


<, > and press e	Selects and plays another CMF file if more than one file is specified.


�
Audio CD Control Hot Keys


The following are the hot keys you can use while playing audio CDs:


C	Resumes playing a track.


^	Stops the track (if one is playing) and exits the program.


F	Fast-forwards the track.


L	Plays the previous track in a specified set.


N	Plays the next track in a specified set.


P	Plays a track.


R 	Rewinds a track.


S	Stops a track.


k	Pauses a playing track.


X	Exits the program.


Record Utility


The Record utility allows you to record sound to a file by specifying the file type and recording parameters such as the sampling rate and the recording mode.


Sound is recorded into a sound file in Microsoft Wave (.WAV) or Creative Voice (.VOC) file format.  


Knowing the Record Command


Before you record a sound file in wave or voice format, you should be familiar with the command line syntax of Record.  


The command line for recording wave or voice files is:


RECORD file [/A:xx] [/C:xx] [/M:xx] [/R:xx] [/S:x] [/Q] [/H] [/?]


where:


file	Specifies the name of the file and its extension, .WAV or .VOC you want to record sound data into.


/A:xx	Sets the record source.


	xx = MIC, CD, LINE or FM


��
You can record from more than one source.�
�
/C:xx 	Sets the compression format.


	xx = ALAW, MULAW or CTADPCM


/M:xx	Sets the record mode.


	xx = MONO or STEREO


/R:xx	Sets the sample size.


	xx = 8 or 16 bits


��
The higher the sampling resolution, the better is the recording quality.�
�
/S:xx	Sets the sampling rate.


	For .VOC format:    xx = 5000 to 44100 Hz


	For .WAV format:    xx = 11025, 22050 or 44100 Hz


��
The higher the sampling resolution, the better is the recording quality.�
�
/Q	Disables display of record information.


/H or /?	Displays a description on using Record.


Take note of the following when using Record:


If you enter Record without any parameters, the online description for using Record appears.


If you did not specify the recording mode, sampling rate and sample size, sound recording is in mono 8–bit wave file format with 11025 Hz sampling rate.


If you want to stop the recording, press ^.


Recording stops automatically when the disk is full.	


Record creates a new file or overwrites an existing file for recording. 


Using Record


The following are some examples of how you can record sound files in DOS:


To record from a CD to a sound file (SONG.VOC) in .VOC format:


1.	Play your CD.


2.	Type RECORD SONG.VOC /A:CD and press e.


To record a sound file without displaying the recording information, type RECORD SONG.VOC /A:CD /Q and press e.


To record a stereo sound file from a line-in source in .WAV format with MULAW compression, type RECORD SONG.WAV /A:LINE /M:STEREO /C:MULAW and press e.


Mixerset Utility


The Mixerset utility allows you to control the Mixer settings interactively.  With the mixer, you can control the volume of various audio sources supported by the card.


You can use the utility as a command at the DOS prompt or invoke the Mixerset interface to control the Mixer settings through a full-screen window consisting of check boxes and sliders.


Knowing the Mixerset Command


The mixer is configured using switches that follow the Mixerset command. 


To use the Mixerset command:


1.	Change to your sound directory.


2.	Type MIXERSET [switches] ...  and press e


where [switches] can be one or a combination of any of the following:


/? or /H	Displays help messages.


/Q	Runs Mixerset without displaying the setting information.


/P	Sets the mixer according to the PRESET settings in the CTMIX.CFG file.


/MA:n;x 	Sets the master volume and balance of the left and right channels.


/VO:n;x	Sets the voice volume and balance of the left and right channels.


/MI:n;x	Sets the MIDI volume and balance of the left and right channels.


/CD:n;x	Sets the CD volume and balance of the left and right channels.


/LI:n;x	Sets the Line-in volume and balance of the left and right channels.


/MIC:n 	Sets the microphone volume.


/SP:n 	Sets the PC speaker volume.


��
n specifies the volume level and ranges from 0 to 255.	��x specifies the balance of the left and right channels and ranges from -5 to +5.  x must be preceded by ‘;’.�
�
For example, /MA:200;5 sets the master volume at 200 and the balance at 5 (this means that the volume will be reduced in the left channel). /MA:;-5 setting reduces the volume in the right channel.


/OPS:ss	Sets the audio output switches (OPSW) on or off.  ss represents one or a combination of CDz, LIz and MICz, where z is + (on) or - (off).


For example, /OPS:CD+ MIC- allows you to receive CD-audio output.  It does not allow any sound passed through the microphone to be sent to the speakers.


/IPL:ss 	Turns Left Input switches (IPLSW) on or off.  ss represents one or a combination of CDRz, CDLz, MDLz, MDRz, LIRz, LILz, and MICz, where z is + (on) or - (off).


/IPR:ss 	Turns Right Input switches (IPRSW) on or off.  Same as /IPL.


/AGC:+|-	Turns Automatic Gain Control (AGC) on (+) or off (-).


Using the Mixerset Command


The following are some examples on how you can use Mixerset:


To set the PC speaker volume to 200, type MIXERSET /SP:200 and press e.


To set the master volume to 200 with balanced output through the left and right channels, type MIXERSET /MA:200 and press e.  If balance is not specified, both channels are set equally.


To set all of the above in one command, type MIXERSET /SP:200 /MA:200;0 and press e.


�
Starting the Mixerset Control Screen


To start the Mixerset Control Screen:


1.	Change to your sound directory.


2.	Type MIXERSET and press e.  The Mixerset Control Screen appears.


�


Knowing the Mixerset Control Screen


The Mixerset Control Screen consists of the following components:


Volume slider


Balance slider


Automatic Gain Control check box


Save button


Input box


Output box


Volume Slider


Controls the volume levels of the input sources.


Balance Slider


The sliders control the balance of the left and right speakers for audio sources with stereo capability.  Moving the slider to the left decreases the volume of the right speaker but the left speaker volume unaffected.  The opposite applies when you move the slider to the right.


Automatic Gain Control Check Box


The Automatic Gain Control (AGC) check box automatically adjusts input gain from the microphone to a level suitable for recording.


Save Button


The Save button saves all changes made to the mixer to the CTMIX.CFG file.  The new setting takes effect the next time you preset the mixer with the command MIXERSET /P.


Input Box


The Input Box enables you to select the audio sources you want to control as input to the mixer.  The audio sources available are MIDI, line and microphone input, and CD-audio.  You can direct these audio sources through the left or/and right input channels of your mixer.


��
To get a stereo sound effect, make sure that the left channel signal of the audio source is directed to the left-in channel and the right signal to the right-in channel.�
�
Output Box


The Output Box enables you to select the audio sources you want to control as output from the microphone, line-in, and CD-audio to the left and right speakers.  You can select one or a combination of the above audio sources playing through the card.


Configuring the Mixer


Using the Mixerset interface, the mixer can be configured with a mouse or a keyboard.  


Using a mouse:


Choose the option if it is a check box.


Move the slider by the click and drag method or click at the extreme end of the slider to increase or decrease the volume.


To quit Mixerset, click on the Control-menu box.


Using a keyboard:


Press v to move from one group to another. 


Press j v to move to a previous group.


Press w, y to move from one option to another within a group.


Press x, z to adjust volume.


Press k or e to select or deselect a check box.


To quit Mixerset, press ^.
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